???: Mysteriously appearing characters

Report issues, odd behaviors or submit a detailed bug report.
Post Reply
User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

???: Mysteriously appearing characters

Post by primehalo » 05 Jun 2017 23:51

Today I was editing an existing line and mysterious characters showed up while I was typing, then disappeared. The characters were characters that appeared elsewhere on the line, so it's like they were duplicated. I shut down and restarted figuring it was a temporary glitch, but then a similar thing happened minutes later. I've attached two screenshots. In them I am typing the word "sort" on line 41, and as soon as I type the "r" in sort the letter "a" appears after the tab. When I type the "t" the "a" disappears. If I turn on the display of special characters, then the "a" does not appear. Also, if I copy the lines of text, the "a" does not get copied so it appears to just be a display error. I was able to recreate this in a separate 2-line PHP file:

Code: Select all

<?php
		$this->sort 	= $aa->get_var('sort', '');
Attachments
02.png
02.png (6.75 KiB) Viewed 1448 times
01.png
01.png (6.7 KiB) Viewed 1448 times

User avatar
Rickard Johansson
Site Admin
Posts: 5345
Joined: 19 Jul 2006 14:29

Re: Mysteriously appearing characters

Post by Rickard Johansson » 06 Jun 2017 10:31

Unfortunately I can't reproduce it. Would you mind sending me your settings file? (You can find it here: <AppData>\Roaming\RJ TextEd\TextEd.ini)

User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

Re: Mysteriously appearing characters

Post by primehalo » 07 Jun 2017 03:11

I have sent the file via email

User avatar
Rickard Johansson
Site Admin
Posts: 5345
Joined: 19 Jul 2006 14:29

Re: Mysteriously appearing characters

Post by Rickard Johansson » 07 Jun 2017 11:53

I still can't reproduce it :? Do you get the same result if you change tab size, font size ...

User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

Re: ???: Mysteriously appearing characters

Post by primehalo » 07 Jun 2017 17:10

I'm not being able to reproduce it either now.

Post Reply