NOBUG: Hexadecimal Viewer not right

Report issues, odd behaviors or submit a detailed bug report.
Post Reply
ar18
Posts: 20
Joined: 10 Sep 2010 02:43

NOBUG: Hexadecimal Viewer not right

Post by ar18 » 07 Jun 2017 01:49

I have a UTF-8 with BOM document and when I select View-->Hexadecimal view, it shows all characters below (128 decimal) as UTF-16 instead of UTF-8, e.g. -- in UTF-16 a space would be 0020h and in UTF-8 it should be just 20h, but instead it is 0020h.

RJ TextEd version: 12.11 (64-bit)
Windows 7 Home (64-bit)

User avatar
Rickard Johansson
Site Admin
Posts: 5312
Joined: 19 Jul 2006 14:29

Re: Hexadecimal Viewer not right

Post by Rickard Johansson » 07 Jun 2017 11:33

Please find the section "Hexadecimal View" at https://www.rj-texted.se/Help/ViewMenu.html.

ar18
Posts: 20
Joined: 10 Sep 2010 02:43

Re: Hexadecimal Viewer not right

Post by ar18 » 07 Jun 2017 18:47

Rickard Johansson wrote:Please find the section "Hexadecimal View" at https://www.rj-texted.se/Help/ViewMenu.html.
Yeah, I saw that before but now I think of it differently. I had no idea what "internal document" was referring to, but now I can see that it tells me that RJ TextEd converts all documents into UTF-16 files, and only displays those documents as hexadecimal. So it really isn't a hexadecimal viewer, it is a file-to-UTF16-to-hexadecimal converter. That makes it pretty much useless as a hexadecimal viewer, especially when you want to do things like byte align UTF-8 files. Most of the Linux world doesn't use UTF-16, but UTF-8, so I wonder why the unconventional use of an atypical format?

So I would like to change this from a bug, to suggestion: get rid of the useless "hexadecimal viewer" and either use an actual hexadecimal viewer that just reads documents or files as they are in real life...or...change the misleading name from "hexadecimal viewer" to "UTF-16 hexadecimal viewer".

User avatar
Rickard Johansson
Site Admin
Posts: 5312
Joined: 19 Jul 2006 14:29

Re: NOBUG: Hexadecimal Viewer not right

Post by Rickard Johansson » 07 Jun 2017 23:09

The easiest way to do what you want is to:

1. Open a UTF-8 encoded file.
2. Go to "File -> Reopen with encoding -> Hexadecimal".
3. Edit and save.
4. Go to "File -> Reopen with encoding -> UTF-8".

I'll add an option in a later version to do the same when using "Toggle hex view".

ar18
Posts: 20
Joined: 10 Sep 2010 02:43

Re: NOBUG: Hexadecimal Viewer not right

Post by ar18 » 07 Jun 2017 23:29

Okay, it is kinda of kludgy but RJ TextEd just might be my favorite editor ever. Even if you don't change it, it will still be my most favorite editor ever. :P

User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

Re: NOBUG: Hexadecimal Viewer not right

Post by primehalo » 25 Jun 2017 02:11

It's my favorite editor as well. I used UltraEdit for the longest time before finding RJ TextEd. Sometimes I use the built in hex view if I just need to view something real quick, but for actual editing of binary files I use HxD. I set it up as a tool in RJ TextEd.

Post Reply