FIXED: Invisible Cursor

Report issues, odd behaviors or submit a detailed bug report.
Post Reply
User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

FIXED: Invisible Cursor

Post by primehalo » 08 Sep 2017 00:50

RJ TextEd just updated to 12.32 today and ever since I've been having an invisible cursor issue. In text files when word wrap is on and there are not enough lines to make the vertical scroll bar show up then the cursor doesn't show up. If I turn word wrap off then the cursor is visible again, and if I make the text file long enough to make the vertical scroll bar show up then the cursor also appears again. This is the 64-bit version on Windows 10.

AndreasW
Posts: 48
Joined: 30 May 2017 07:22

Re: Invisible Cursor

Post by AndreasW » 08 Sep 2017 07:57

I see this problem too.

User avatar
primehalo
Posts: 136
Joined: 16 Jun 2011 03:10
Contact:

Re: Invisible Cursor

Post by primehalo » 08 Sep 2017 08:20

Apparently it's not just the cursor. I've had dialog boxes that were invisible, such as when I deleted a file in Explorer that was open in RJ TextEd and no dialog box showed up, except the dialog box was obviously there somewhere because I couldn't do anything and it kept making that sound effect whenever I tried. I had to use task explorer to terminate the program. Also, all of the sub-menus such as View > Bars and Format > Encoding.

User avatar
Rickard Johansson
Site Admin
Posts: 5345
Joined: 19 Jul 2006 14:29

Re: Invisible Cursor

Post by Rickard Johansson » 08 Sep 2017 10:47

I've tried everything I can think of, but no luck. I can't see the invisible cursor :?
Could you give me an example text with some instructions on how to reproduce it?

User avatar
Rickard Johansson
Site Admin
Posts: 5345
Joined: 19 Jul 2006 14:29

Re: Invisible Cursor

Post by Rickard Johansson » 08 Sep 2017 11:10

Your settings file may help as well (<AppData>\Roaming\RJ TextEd\TextEd.ini).

AndreasW
Posts: 48
Joined: 30 May 2017 07:22

Re: Invisible Cursor

Post by AndreasW » 08 Sep 2017 11:21

Just open a new file, make sure that word-wrap is on, and then press the key "a" and keep it pressed. As a result, due to auto-repeat, you will get a lot of "a":

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

This should be sufficient to reproduce the error.

User avatar
Rickard Johansson
Site Admin
Posts: 5345
Joined: 19 Jul 2006 14:29

Re: Invisible Cursor

Post by Rickard Johansson » 08 Sep 2017 12:10

Thanks, it's been fixed.

Post Reply