FIXED: EoL Replace

Report issues, odd behaviors or submit a detailed bug report.
Post Reply
User avatar
rjbill
Posts: 785
Joined: 13 Jun 2011 06:36

FIXED: EoL Replace

Post by rjbill » 14 Jan 2018 04:00

I don't know if this is a bug, or what.

I did a RegEx Global Replace of "\>" with ">\r\n" and it did it,
putting a blank line (actually, TWO blank lines) after the end of every HTML statement.

Then I opened another file to do the same, and it won't work in it.

I can't figure out what is going on.

I was just messing with it, and I did the Replace and nothing happened,
so I did the Replace again and it did it.

So I think it is a bug of some sort.

And WHY is it doing TWO EoLs with a blank line in between??
RJTE version 13.30 (actual) - 64-bit
Win 10 64-bit 8 GB RAM

Note: The signature is dynamic, not static,
so it may not show the correct version above
that was in use at the time of the post.

User avatar
Rickard Johansson
Site Admin
Posts: 5550
Joined: 19 Jul 2006 14:29

Re: EoL Replace

Post by Rickard Johansson » 16 Jan 2018 21:28

I can't see anything wrong. As far as I can see it only adds one linefeed after each replaced item.

User avatar
rjbill
Posts: 785
Joined: 13 Jun 2011 06:36

Re: ??? EoL Replace

Post by rjbill » 16 Jan 2018 22:19

What happens is this.

I have an HTML file that is "compressed" into one long line.

When I do the Replace, the screen blinks, but it doesn't refresh.

So I thought it didn't do the Replace, so I did another one, after which
it did refresh, and that's why there was a blank line between every line.

I just did it again from the beginning, and I clicked on the scroll bar, and it scrolled down
and refreshed the screen correctly, having worked correctly.

So for some reason, when the file is one long line, it's not refreshing
after the Replace. That is the problem and bug.
RJTE version 13.30 (actual) - 64-bit
Win 10 64-bit 8 GB RAM

Note: The signature is dynamic, not static,
so it may not show the correct version above
that was in use at the time of the post.

User avatar
Rickard Johansson
Site Admin
Posts: 5550
Joined: 19 Jul 2006 14:29

Re: ??? EoL Replace

Post by Rickard Johansson » 17 Jan 2018 13:29

Should work in next release (v12.70). Thanks!

Post Reply