TElMenuItem Question

Ask questions about how to create a script or swap scripts with other users.
Post Reply
quy
Posts: 3
Joined: 28 Oct 2019 10:32

TElMenuItem Question

Post by quy » 08 Nov 2019 02:41

When I use the TElMenuItem, it seems like don't work as expected, so as the TForm's Color property.
My Computer sysetem is win10 64.

User avatar
pjj
Posts: 1677
Joined: 13 Oct 2009 13:48
Location: Kraków, Poland

Re: TElMenuItem Question

Post by pjj » 08 Nov 2019 09:10

And what's your question, exactly? (Screenshots, code snippets will help, too.)
Alium tibi quaere fratrem; hic, quem tuum putas, meus est. Titus Flāvius Caesar Vespasiānus Augustus

quy
Posts: 3
Joined: 28 Oct 2019 10:32

Re: TElMenuItem Question

Post by quy » 09 Nov 2019 07:19

the attachment are the code and screenshot
Attachments
TElMenuItem.png
TElMenuItem.png (21.66 KiB) Viewed 103 times

User avatar
pjj
Posts: 1677
Joined: 13 Oct 2009 13:48
Location: Kraków, Poland

Re: TElMenuItem Question

Post by pjj » 09 Nov 2019 09:27

As you can see, It works for me (Win 7), and other colors do too, so clearly this is a bug and it needs Rickard's attention.
blue-modal.png
blue-modal.png (7.9 KiB) Viewed 99 times

Nb. it would be nice to post your minimal code as text, so one could copy it; here's your code for Rickard to use:

Code: Select all

var f;

f = new TForm(nil);
f.Caption = "Test";
f.Color = clGreen;

f.ShowModal;
f.Free;
Alium tibi quaere fratrem; hic, quem tuum putas, meus est. Titus Flāvius Caesar Vespasiānus Augustus

quy
Posts: 3
Joined: 28 Oct 2019 10:32

Re: TElMenuItem Question

Post by quy » 09 Nov 2019 11:37

Thank you for your reply

Post Reply