Navigation: TextEd > Extension and Scripts >

Create a new script

 

 

 

FastScript


The script language used is called "FastScript". You can choose between four different syntax types. JScript, C++, Pascal or Basic. Please note that these are only different syntaxes and not different script languages.

All script files should be saved as UTF-8 encoded (with a BOM).

 


Create and manage scripts

All user script functions are located in the script menu and on the user toolbar.
 


Use the menu items, or toolbar, to create new script files, open existing scripts or save scripts when done. Please make sure the script is saved as Unicode UTF-8.

Always open a script from the script menu or toolbar to ensure that highlighting and auto completion is working properly.


To run and test your script you need to enable dual document view (two document panes side by side). Open the script on the left side and a test document (document to test the script on) on the right side.

 


Completion list

Press Ctrl+Space to open a completion list. This list contain the default objects and some useful functions you can use in your scripts.

 

If you select or type a default object and a dot (.) the object auto completion list is displayed

 

E.g. Document.

 

 

Add a script to the program

Scripts can be added to the script menu or you can add the script as a tool. A tool can be added to the tools menu, user tool bar or the editor tool bar. Open "Options -> Tools menu", as seen below.

 


Press "Add" to add the script to the list.

 

Change Type to "Script (.cpp|.js|.pas|.vb)" and press the "Open file..." button to select your script. Change the name, if you like, and maybe add a sub menu (optional).

 


The Run script drop down list enable you run the script when a specified action occur. Above its set to "only manually". We only want to run the script when selected from the "Tools" menu or pressing a tool bar button.

 

Press "OK"

 

 

The script is displayed in the list. We can now assign a shortcut to the script and add it to any toolbar.

If you want to add the script to a toolbar - don't forget to select an icon.


 

Press "OK". Our script is now visible in the "Tools" menu.


 




 

 

 

 

Copyright © 2022 Rickard Johansson