Navigation: TextEd > Introduction > Tutorials and misc functions >

Remote files (FTP,SFTP)

 

 

 

The editor can handle remote files almost as if they were local files. You open remote files using the FTP panel or from the file commander. Opened files are stored in the last open file list, which makes it simple to re-open the files.

 

New documents can easily be uploaded using the menu items in "File -> FTP".

 

There are a some options (Options -> File -> Save remote files) available to set a default action when a remote file is saved using "File -> Save (Ctrl+S)". Available options (default actions) are listed below.


 

Save to local location


Use this options if you want to save both local and remote files to a local disk. In this working mode you can edit remote files and store them locally until they are ready to be uploaded. You can use the menu items in "File -> FTP" to upload the files. You can also use the file commander.


 

Save to remote location


Local files are always saved locally. Remote files are saved (uploaded) to the server. This is the default behavior.

 

If you create a new document and upload it to a server - the file will always be saved to the server.

If you open a remote file - it will always be saved to the server.

If you create a new document and first save it locally and then upload it - it is considered a local file and always saved to disk.

If you open a local file and upload it to the server - the file is still considered local and always saved to disk.
 

 

Save to both local and remote location


Pure local files are always saved locally. But if a file has been uploaded to a server - it will always be saved to both the local disk and uploaded to the server. It doesn't matter if the file was opened from disk or the server.

 

If you create a new document and upload it to a server - the file will always be saved to both disk and server. If a local path doesn't exists - a file save dialog window is opened.

If you open a remote file and save - the file is always saved to both disk and server. A save file dialog window is displayed if needed.

If you open a local file, that has previously been saved to a server - it will always be saved to both disk and server.


 

Ask me once for every new (or opened) document


With this option set you are prompted for an action when you hit save. The actions are the same as above.

The action is remembered as long as the document is open.

 

 

 

 

 

 

 

 

Copyright © 2022 Rickard Johansson